Categorias
Configuração Tema wordpress

temas

minhas anotações sobre temas

Referências

Categorias
administração Administração Atualização Configuração Instalação versão versão wordpress

WordPress 5.5 “Eckstine”

Anotações sobre o WordPress 5.5 “Eckstine”

Referências

Categorias
administração Administração Casos Configuração Hospedagem wordpress

HTTP ERROR 500

Esta página não está funcionando
compoucador.com.br não consegue atender a esta solicitação no momento.
HTTP ERROR 500

Mensagem de erro ao tentar fazer login no site WordPress.

Permissões de Acesso

O arquivo login.php da raiz estava com permissão de acesso 00! Alterando de volta para 644, tudo voltou ao normal. Mas, a pergunta que fica é “O que causou esta mudança de permissão?” Acho que já vi este problema anteriormente. Será que foi neste mesmo servidor/hospedeiro?

Referencias

Categorias
administração Administração aprendizado Configuração Hospedagem Instalação Performance Segurança versão wordpress

Atualização de PHP

Atenção:Atualização do PHP necessária

O WordPress detectou que este site está sendo executado em uma versão insegura do PHP.

Provedor Também Recomenda

Warning: PHP versions PHP 7.0 e PHP 7.1 are deprecated. Recomendamos que você atualize para uma versão suportada do PHP.

Aviso no painel da hospedagem.

Erro com o PHP 7.4

Warning: Use of undefined constant WP_CONTENT_DIR – assumed ‘WP_CONTENT_DIR’ (this will throw an Error in a future version of PHP) in /home2/ccacam46/public_html/wp-includes/load.php on line 141

Parece que em sua instalação do PHP está faltando a extensão MySQL, que é requisitada pelo WordPress.

Deprecated: Directive ‘allow_url_include’ is deprecated in Unknown on line 0

O problema e sua Correção

O provedor implementa as multiplas versões de PHP para as suas hospedagens indicando a versão de PHP a ser usada por diretivas no arquivo de configurações .htaccess!

Este arquivo é atualizado pelo painel da hospedagem com as novas diretivas quando da troca de versões de PHP.

Por caracteristica de funcionamento do arquivo .htaccess, as suas múltiplas versões, se existirem se interagem. Foi este o caso. Um dos arquivos .htaccess presente na hospedagem estava apontando para outra versão do PHP. Corrigido o problema, tudo voltou a funcionar normalmente.

Referências

Atualização do PHP necessária

Alternar painel: Atualização do PHP necessária

O que é PHP e como isso afeta o meu site?

PHP é a linguagem de programação que usamos para construir e manter o WordPress. Versões mais recentes do PHP são mais rápidas e mais seguras, portanto, a atualização terá um efeito positivo no desempenho do seu site.

Mensagem do painel de administração do site.
Categorias
administração Administração Atualização Configuração editor Instalação versão wordpress

WP 5.4

Anotações sobre o WP 5.4 e seu lançamento.

Categorias
administração Configuração wordpress

Plugin

Referencia

  1. What is a WordPress Plugin?
Categorias
aprendizado Configuração Tema wordpress

Responsividade

Afinal, as telas de celulares e tablets já predominam entre os acessos.

Referencias

Categorias
administração Configuração Tema

Temas …

Chega uma hora em que queremos entender um pouco melhor o funcionamento dos temas no WP.

The anatomy of a WordPress theme é realmente uma leitura fundamental para quem quer lidar com o assunto. Ainda prefiro o anterior, mas este também tem algumas ideias que podem ajudar. Anatomy of a WordPress theme.

Para ver isso, a minha ideia é criar um tema do zero, como proposto em

Alternativamente, no WordCamp Sampa 2012 assisti a palestra Desenhando um tema com CSS e _s do MAtias Ventura que pode ser de muito interesse.

 

Referências

Categorias
administração Configuração editor Performance wordpress

Fotos e Imagens

Referências

Categorias
wordpress

Tradução

Anotações sobre o trabalho de tradução de temas e plugins wordpress.

PO & MO

 

Referencia